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	Using Drawing Tools

The toolbox shown in visual contains Flash drawing tools and other tools you’ll need to create and manipulate graphics in order to make animations. The Tools section contains drawing, painting, and selection tools. The View section contains tools for zooming and panning the application window.  The Colors and Options sections contain modifiers for the selected tool, which affect the tool’s painting or editing operations.


NOTE: To preview your animation at any time, press ctrl + enter 
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Flash Exercises
*Always set your stage to 800 x 600 px, unless otherwise specified

Exercise 0: Folder Organization
· Inside your 2D Animation folder, create a new folder called “CGI Animation.” Inside this folder create a new folder called “IntroExercises.” This is where you will be saving all of the working and final versions of the exercise files below.

Exercise 1: Playing with Drawing Objects 
· Open a new flash document (ActionScript 3.0)
· Save this file as animalpic (.fla – aka your “working file”)

Use the shape, line, pencil, paintbrush and pen tools to draw a simple animal of your choosing. Include the body, tail, head and legs. On the head include eyes, ears, nose, mouth and other defining features.
· Make sure that your “object drawing” button is highlighted (AKA in “Drawing Object” mode). This will produce a “drawing,” which is a non-merge-able object.
· Note: If you forgot to change your “object drawing mode” to “Drawing  Object” you can convert your “Shape” to a Drawing Object by selecting the object, then clicking Modify > Combine Objects > Union.

	Use the following techniques: Color Swatch

· At least 2 different shapes
· At least 2 different stroke and fill colours
· Both straight and curved lines
· Pencil/Brush strokes of different heights/types (tip: make sure that settings are set to smooth)
· Paintbucket tool to change fill colour

Instructions:
1. Draw your animal using the drawing tools mentioned above. Make sure that your animal’s feet are planted on the bottom of the stage.
2. Change your document settings (Modify > Document) so that your Ruler Units are set to inches, rather than pixels.
3. Select all parts of your animal (click and drag around the entire animal with the Selection Arrow or shift + click all parts of the animal).
4. In the Properties Panel (on the righthand side of your screen), adjust the Position and Size properties so that your animal is approximately 3” x 3” (note: exact sizes will vary depending on the dimensions of the animal).
5. Export your file as a PNG image (File > Export > Export Image), file format: .png; name: “animalpic.” In the “Export PNG” dialog box that pops up, change the dpi from 72 to 300 and hit “ok.”
6. Save your working file (aka .fla file) and exit.
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Exercise 2: Playing with Shape Objects (save as starpic)
· Open a new flash document (ActionScript 3.0)
· Save this file as starpic (.fla)

Use the star and circle shape tools with fill only (no stroke) to produce an effect that makes it look as though a group of stars is jumping out of a star-shaped hole!
· Make sure that your “object drawing” button is NOT highlighted (aka in “Shape” mode). This will produce a “shape” which is a merge-able (aka cookie-cutter) object.
· Note: If you forgot to change your “object drawing mode” to “Shape” you can convert your “Drawing Object” to a Shape by selecting the object, then clicking Modify > Break Apart.

Use the following Techniques:
· Drawing using “Shape” Drawing Object Mode (which merges shapes)
· Drawing using the Rectangle and Polystar tools
· Duplicating objects
· Grouping objects
· Adding and adjusting text

Instructions:
1. View the ruler (View > Ruler), and set the ruler unit to inches (Modify > Document).
2. Click on the Circle Shape tool. Change the stroke setting to “no stroke” (a white box with a red line through it). Create a circle that is 5” in diameter. To do this, use the Properties Tab. To create a circle that remains perfectly shaped during resize, make sure that the “lock width and height values together” button (it looks like a linked or broken chain) is selected.
3. Drag the circle to the top left-hand corner of the stage.
4. Create a star (also with no stroke, and a different fill colour than your circle) and drop it on top of the circle to create a star-shaped cutout. Note: you must click off the star to apply the cutout transformation.
5. Move the star off of the circle and duplicate it (Edit > Duplicate or Ctrl + D). Change the color and duplicate again until you have 5 stars. Be careful with where you place these stars – since you are in “shape” mode, they will have a cookie-cutter effect.
6. Group all 5 stars together (Shift + Click each, then Modify > Group), reposition and resize the star group so the bottom points reach to the bottom of the stage (note: you may also have to select and move the circle shape).
7. Add classic, static text that says “It’s all an illusion” across the top of the stage. Change the font size, style and colour to suit your image.
8. File > Export > Export Image > .png file format (name it starpic)
9. Save your working file (aka .fla file) and exit.
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Exercise 3: Layers & Frame-By-Frame Animation (save as animalmov)
· Open a new flash document (ActionScript 3.0)
· Save this file as animalmov (.fla)

Create a simple animation in which the animal you created in Exercise 1 shrinks and grows while a sun rises and sets in the background. Include a background, complete with any necessary props and landscaping items. Make sure that each of your objects (aka anything that is drawn) is on a separate layer.
· You may choose to either leave your “object drawing button” highlighted or NOT highlighted. To me, highlighted (drawing object/non-mergeable) mode is MUCH easier to work with.

Use the Following Techniques:
· Importing objects into to the Library Panel
· Tracing an image (aka converting a bitmap to a vector image)
· Altering the movie properties (in the properties panel)
· Creating, organizing and naming layers
· Displaying gridlines across the stage
· Inserting keyframes and standard frames on the timeline
· Creating smooth frame-by-frame transitions and animations

Instructions:
Set up the document
1. Set the movie properties so that the frame rate is 12 fps, and the ruler unit is inches (Modify > Document). 
2. Display gridlines on the stage (View > Grid > Show Grid)

Import and trace
3. Import the animalpic.png (image) file you created in Exercise 1 to your stage by clicking File > Import…>Import to Library, then navigating to and opening your file. The image will now appear under your Library Panel.
4. Drag an “instance” of your animalpic onto the stage. 
5. Trace your image (which makes is a scalable vector shape) by selecting it, then clicking Modify > Bitmap > Trace Bitmap… Play around with the settings in the popup, then keep hitting “Preview” until you get a fairly accurate trace. Then click “ok.”
6. Select all separate parts of your animal and Modify > Combine Objects > Union them (to form a single object).
7. Resize your animal so that it takes up approximately 1/3 of the stage, height-wise.

Animate the animal
8. Insert a keyframe (right click on the desired frame location or left-click on the frame and hit F6) at frame 2.
9. With keyframe 2 selected, reduce the size of the animal by 1 grid point (Use the Free Transform tool then drag the bounding box down from the corner while holding the Shift key). Keep the legs of the animal in their original place, if at all possible. We do not want the appearance of movement – just shrinking and growing.
10. Continue creating keyframes and reducing the size of the animal an equal amount for 10 frames.
11. Select all 10 frames on the timeline (by shift-selecting or drag-selecting), then right-click to copy and paste them to frame 11 (this should create an additional 10 frames, for a total of 20 frames).
12. Select frames 11-20, then right-click and select “reverse frames.” This will cause the animal to grow back to its original size (in frame 1).
13. Change the name of layer 1 to ShrinkingAnimal. Lock the ShrinkingAnimal layer (this prevents you from making accidental changes to this layer while you work on other layers). Toggle (turn on and off) the visibility of the ShrinkingAnimal layer as you work on the Background layer (this keeps this layer’s content out of your way as you work on other layers).
14. Insert a new layer (Insert>Timeline>Layer or click the “New Layer” icon at the bottom of the Layers panel) and name it “Background.” Create an outdoor background for your animal using an assortment of drawing tools. To create the sky, simply change the stage colour (in the Properties Panel). To create the ground, simply draw a rectangle where you’d like the ground to be. Extend the Background layer so that it lasts for the entire movie (do this by adding 20 standard frames to the Background layer timeline). Remember, the Background layer must be underneath the ShrinkingAnimal layer.

Animate the sun
15. Create a new layer called Sun, and make sure it is placed above the Background layer.
16. Create a sun in the sky.
17. Create an animation that will see the sun set through the 20 frames of the movie.

Save and export
18. File > Export > Export Movie > .swf file format (name it animalmov) 
19. Save your working file (aka .fla file) and exit.
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Info Break: The 3 Types of Symbols
1. What is a symbol?
· A symbol is an animatable drawing object. In order to apply Classic and Motion Tweens to your drawing objects, you must first convert them into symbols.
2. What are the 3 types of symbols?
· Graphic, Movie, and Button
3. What is a Graphic Symbol?
· A symbol that is used for static artwork, or animations without interaction (ActionScript).
· Supports nesting, but requires #frames on the main timeline to match up with the #frames on the nested timelines (ex. If the #frames on the main timeline is 1, and the #frames on the nested timeline is 24, the nested animation will not play through).
· Use this symbol whenever possible, since it keeps your file size low
4. What is a Movie Symbol?
· A symbol that is used for static artwork, animations, or interaction (ActionScript).
· Supports nesting, and does not require #frames on the main timeline to match up with the #frames on the nested timelines (ex. If the #frames on the main timeline is 1, and the #frames on the nested timeline is 24, the nested animation will still play through).
· Use this symbol when creating complex animations, or using ActionScript.
5. What is a Button Symbol?
· A symbol that is used for mouse-related interactivity
· Use this symbol when adding audience interactivity with ActionScript
__________________________________________________________________________________

Info Break: The 3 Types of Tweens
1. What is a tween?
· A series of regular frames between two key frames that are automatically generated by Adobe Flash based on the position of the artwork within the starting keyframe and ending keyframe. The biggest difference between the types of tweens below is their workflow.
2. What are the 3 types of tweens?
· Classic, Motion, and Shape
3. What is a Classic Tween?
· A tween that is used for basic motion or rotation
· Can only be used on symbols
· Workflow: Both the beginning and ending keyframes, and any necessary frames in between must be created prior to inserting a Classic Tween. The tween is inserted by right-clicking on any frame in between the beginning and ending keyframes.
4. What is a Motion Tween?
· A tween that is used for complex, customizable motion or rotation
· Can only be used on symbols
· Workflow: Only the beginning keyframe and any number of regular frames must be created prior to inserting a Motion Tween. The tween is inserted by right-clicking on any frame within the motion tween where you would like a new ending keyframe to be defined. With this type of tween, motion can be created on the fly, and its path can be edited later.
5. What is a Shape Tween?
· A tween that is used to transform one shape into another
· Can only be used on shapes (not symbols)
· Workflow: Same as for Classic Tween (but substitute Shape Tween)
Exercise 4: Classic Tweens (save as starmov)
· Open a new flash document (ActionScript 3.0)
· Save this file as starmov (.fla)

Use a classic tween to create a simple animation that contains three stars. One star will slowly disappear and reappear in the center of the stage, while two smaller stars bounce off each other, and the edges of the stage surrounding the central star.
· For this exercise, you will be converting your drawing objects into Graphic Symbols.

Use the Following Techniques:
· Importing objects into to the Library Panel
· Alignment using the Window > Align option
· Converting objects to Graphic Symbols
· Creating a Classic Tween
· Adjusting a Classic Tween’s “Ease” and “Rotation”
· Adjusting a Symbol’s “Color Effects”

Instructions:
Set up the document
1. Set the movie properties so that the frame rate is 12 fps, the stage size is 800 pixels x 600 pixels (aka 11.11 inches x 8.33 inches) and the ruler unit is inches (Modify > Document). 
2. Display gridlines on the stage (View > Grid > Show Grid)
3. Set the stage color to any light shade of your choice.

Draw the star
4. Change the name of “layer 1” to “LeftStar”
5. Use the Polystar tool to draw a 5-pointed star, then separate each point from the center using the line tool (so that you end up with 1 pentagon in the center, and 5 triangles surrounding it).
· To help you with this, make sure that your “Snap to Objects” (magnet) icon is on!
6. Select both the star and the lines you drew, and Modify > Break Apart so that you are able to fill each point of the star and its middle with a different colour.
7. Use the Paintbucket tool to fill each of the star’s points and center with a different colour.
8. Recombine all parts of the star by selecting the entire star, then Modify > Combine Objects > Union.
9. Size the star to approx. 1.5” x 1.5”

Convert the star to a Graphic Symbol, and align
10. Convert the star to a graphic symbol (Modify > Convert to Symbol). Set the “Type” to “Graphic” and the name to “ColouredStar.” This will place a copy of the symbol in your Library, as well as place an instance of your symbol on your stage.
11. Align the instance of the star (that is already on your page) to the top left corner. 
· Note: You may align objects by moving them manually, or by using the Align Window. To bring this window up, select: Window > Align (make sure the “align to stage” box is checked).

Add and adjust a Classic Tween
12. Insert a keyframe on frame 10 and with this keyframe selected, align LeftStar to the bottom left corner. 
· Hint: hold down the shift key as you drag your instance to “snap to grid” (this makes it stay straight)
13. Right-click anywhere between Keyframe 1 and Keyframe 10 and create a Classic Tween.
· If you did this right, you will notice that the frames between Keyframe 1 and 10 have changed from grey to purple and black arrow appears within them.
14. Click on any frame within the Tween to access the Tween’s properties (in the Properties Panel).
15. Under “Tweening” change the “Ease” to 10 and the “Rotate” to CW (clockwise).
Animate LeftStar
16. Select frame 20, insert a keyframe and align LeftStar in the top right corner.
17. [image: starlightlayer1]Right-click anywhere between Keyframe 10 and Keyframe 20, and create a Classic Tween with easing of 10 and a clockwise (CW) rotation.
18. Select frame 30, insert a keyframe and align LeftStar in the bottom right corner.
19. Right-click anywhere between Keyframe 20 and Keyframe 30, and create a Classic Tween with easing of 10 and a clockwise (CW) rotation.
20. Select frame 40, insert a keyframe and align LeftStar in the top left corner.
21. Right-click anywhere between Keyframe 30 and Keyframe 40, and create a Classic Tween with easing of 10 and a clockwise (CW) rotation.
22. LeftStar should appear to move in this direction throughout the animation 

[image: starlightlayer2]Add and animate RightStar
23. Create a second layer, and name it “RightStar”
24. With both the RightStar layer and Frame 1 selected, insert an instance of “ColouredStar” by dragging a copy from the Library to the stage.
25. Align RightStar to the top right corner of the stage (make sure Frame 1 is selected).
26. Duplicate the animation procedure from above, but in reverse. Keep the “Ease” at 10, but change the “Rotate” to Counter-Clockwise (CCW)
27. RightStar should appear to move in this direction throughout the animation 

Add and animate FadeStar
28. Create a third layer, and name it “FadeStar”
29. With both the FadeStar layer and Frame 1 selected, insert an instance of “ColouredStar.” 
30. Increase the size of FadeStar to 3” by 3.”
31. Align FadeStar to the center of the stage.
32. Under the Properties Panel, under “Color Effect” change the “Style” to “Alpha.” Drag the slider to 0%. The star should disappear completely (Alpha refers to an object’s transparency)
33. Insert a keyframe on frame 20, then change the Alpha to 100%
34. Right-click anywhere between Frame 1 and Frame 20 and create a classic tween
35. Insert a keyframe on frame 40, then change the alpha to 0%
36. Right-click anywhere between Frame 20 and Frame 40 and create a classic tween
37. Move the fade layer to the back of the stage (by moving it to the bottom of the layers panel)

Save and Export
38. File > Export > Export Movie > .swf file format (name it starmov).
39. [image: starmov][image: Capturecccccc][image: Captureccc]Save your working file (aka .fla file) and exit.




Exercise 5: Shape Tweens (save as facemov)
· Open a new flash document (ActionScript 3.0)
· Save this file as facemov (.fla)

Use a shape tween to create a simple animation in which a regular old circle morphs into the face of an animal, and then back into a circle again. The effect should make it look as though your animal’s features are appearing out of nowhere, then melting back into its head as quickly as they came!
· For this exercise, you will not be converting your drawing objects into symbols.
· [image: facemov]For this exercise, you must make sure to use only shapes with fills (no STROKES allowed). This means that, for every shape that you draw, you must turn off its stroke color (in the color picker, click the little white box with a red line through it). This also means that you will not be able to use the line tool, unless you plan on creating a shape you can fill in later. It is also very important NOT to group or combine all the separate facial features of your animal.

Use the Following Techniques:
· Create drawing objects with FILL only (no STROKE)
· Arrange drawing objects in relation to one another
· Creating shape tweens (note: Shape tweens can only be applied to shapes)

Instructions:
Set up your stage
1. Set the movie properties so that the frame rate is 24 fps, the stage size is 800 pixels x 600 pixels (aka 11.11 inches x 8.33 inches) and the ruler unit is inches (Modify > Document). 

Draw your objects
2. In frame 1, create a shape (either a rectangle or oval – and you may modify it any way you like). Choose whatever fill colour you like, but make sure the stroke is turned off. This will eventually turn into your animal’s face.
3. Align your shape to the center of the stage (Window > Align)
4. Insert a keyframe on frame 36.
5. On frame 36, turn your circle into the face of an animal (add ears, eyes, nose, mouth, hair, whiskers, etc.). Make sure that you are using FILLS only. If you want to draw freeform, you may use the Brush tool, rather than the pencil tool. 
· This is because the pencil draws using only a Stroke, and the brush draws using only a Fill.

Animate your objects
6. Create a shape tween by right-clicking anywhere between frame 1-36 and choosing “Create Shape Tween.” The space between frame 1 and 36 should have now turned green, and contain a black arrow.
7. Preview your animation by clicking Ctrl + Enter. The shape on frame 1 should morph smoothly into the animal face on frame 36. Do any changes need to be made?
8. It looks like your cat’s face does not stay on the stage long enough for us to get a good look at it. To fix this, click on frame 37 in your timeline and insert a keyframe. This will stop the tween and freeze frame 36’s content (the cat face).  Next, click on frame 46 and add a regular frame (you may also do this by hitting F5 on your keyboard).
9. Preview your animation. The cat’s face should stay on the screen a little longer.
10. Just like you did with the “Shrinking Cat” from Exercise 3, copy frames 1-46 and paste them into frames 47-92 on your timeline. Make sure frames 47-92 are selected, then Reverse the frame order so that the animal’s features morph back into their original shape.
11. Preview your animation. Make any necessary changes.
Advanced: Want more control over your Shape Tween? Learn more about Shape Hints by clicking the hyperlink.

Save and Export
12. File > Export > Export Movie > .swf file format (name it facemov).
13. Save your working file (aka .fla file) and exit.
Exercise 6: Motion Tweens (save as starpathmov)
· Open a new flash document (ActionScript 3.0)
· Save this file as starpathmov (.fla)

Use a motion tween to create a simple animation in which 5 stars move seamlessly from one end of the stage to the other, by following an arched motion path.
· For this exercise, you will be converting your drawing objects into graphic symbols.

Use the Following Techniques:
· Creating motion tweens
· Adjusting motion paths
· Alter a symbol’s Color Effect
· Snap a symbol to a motion path

Instructions:
Set up your stage
1. Set the movie properties so that the stage is 800x600 px (or 11.11 x 8.33 inches), the frame rate is 15fps (if it is not already), and the ruler unit is inches (Modify > Document). 
2. Change the colour of the stage to a darker shade.

Draw your star
3. On frame 1, create a multi-colored star like the one from Exercise 4 (or open the .fla from Exercise 4, then copy and paste the star you used there). 
4. Resize the star so that it is approx. 1.5 x 1.5 inches, and align it to the middle of the left margin.
5. Convert this star to a graphic symbol named “Star.” Make sure the registration point is centered. Click okay.
6. Rename layer 1 to “Multistar”

Animate your Multistar
7. Select frame 24 on your timeline and insert a regular frame.
8. Click anywhere between frame 1-24 on your timeline, and create a Motion Tween (Insert > Motion Tween). The space between frame 1 and frame 24 should now appear blue, instead of grey.
9. Select frame 12 on your timeline. Now, click on your star, and drag it approx. halfway across your stage (hold down the shift key to move it in a straight line), then release it. There should be a coloured (the colour will depend on your layer colour) dotted line following your star. This line shows your star’s motion path, and each dot along it represents a frame on your timeline! These dots are adjustable, as you will soon see.
10. Select frame 24 on your timeline. Now, click on your star, and drag it all the way to the right margin.
11. Using the Selection Arrow, curve the left side of your motion path and pull it down. Then, curve the right side of your motion path and pull it up. Your path should look like a large, diagonal “S.” 
12. Using the Selection Arrow, drag the left-most dot off the stage and onto the pasteboard. Do the same for the right-most dot (which your star is likely sitting on at this point). 
13. Press Ctrl + Enter to preview your animation. It should look like your star travels onto the stage from the left side, travels in an “S-shaped” path across the stage, then disappears off the stage from the right. Over and over again (loop).
14. Drag the playhead back to frame 1 on the timeline.

Add another layer 
15. Create a new layer and name it “BlueStar.”
16. Insert an instance of “Star” (from the library) on the BlueStar layer, and position it on frame 1 so that it is exactly overtop of the first star (on the “Multistar” layer).
17. Select the Multistar layer. Left-click on the motion path to select it, then right-click and choose “Copy Motion.” Return to the Bluestar layer, right-click somewhere between frame 1-24, and paste (right-click and choose “Paste Motion”) the motion path into the timeline. 
18. On the Bluestar timeline, make sure that both your star and frame 1 in the timeline are selected, then use the Properties Panel to change your star’s tint (Color Effect > Style > Tint) to blue.
· If your tint is not having much of an effect, drag the “tint” slidebar until it has the desired effect
19. On the Bluestar layer’s timeline, hover your mouse over frame 24 until you see a short black line with an arrow on either side. Once you see this symbol, click the end of frame 24 and drag the length of 3 frames to the right (now your blue bar should end on frame 27 instead of frame 24). 
· This will make your bluestar look like it is following your multistar!
20. Press Ctrl + Enter to preview your animation.

Add even more layers
21. Repeat steps 13-17 three more times to create the following layers: “YellowStar”, “GreenStar”, and “Redstar.” Each star should be tinted to the colour in the layer name. 
· If you have done each step correctly, your “RedStar” layer’s timeline should be 36 frames long.

Save and export
22. File > Export > Export Movie > .swf file format (name it starpathmov).
23. Save your working file (aka .fla file) and exit.
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__________________________________________________________________________________

Info Break: Nested Animation

What is a “nested animation”?
Essentially, it is an animation within an animation. To produce a nested animation, you must convert your artwork into a Movie Symbol. Double-clicking on an instance of this Movie Symbol on the stage allows you to “step inside” the main timeline to enter that specific Movie Symbol’s own unique timeline. This allows you to create more complex animations, wherein your artwork can be animated both inside its own timeline, and on the main timeline.

Exercise 7: Nested Animation & Custom Motion Paths (save as nestedmov)
· Open the “nestedmov” .fla file from the Shared > Hammond > Hand Out > 2D Animation folder
· Save this file as nestedmov (.fla) within your “Exercises” folder

Create a nested animation wherein an alien follows a custom motion path to move across the stage, while simultaneously waving his arms in the air like he just don’t care.
· For this exercise, you will be converting your alien (the main drawing object) into a Movie Symbol
· You will also be converting the 5 pieces of your alien (the minor drawing objects) into Graphic Symbols

Use the Following Techniques:
· Converting a Drawing Object to a Movie Symbol
· Creating and snapping symbols to custom motion paths
· Creating a nested animation

Instructions:
Set up your stage
1. Set the movie properties so that the stage is 800x600 px (or 11.11 x 8.33 inches), the frame rate is 24fps (if it is not already), and the ruler unit is inches (Modify > Document). 
2. Change the colour of the stage to a colour that complements the alien.

Convert the a drawing object to a movie symbol
3. Take a look at the artwork on your stage. Click on each part of the alien – notice that there are 5 separate parts in total, and that each is a Drawing Object. 
4. Select the alien’s head, left arm, right arm, top, and bottom all at once, then convert them to a movie symbol by selecting Modify > Convert to Symbol (or f8). Set the “Name” to “Alien,” and the “Type” to “Movie Clip.” Click the Library panel. Inside, there should now be a reusable Movie Clip called “Alien.”

Convert the movie clip’s parts to graphic symbols
5. Double-click the alien movie clip on your stage to enter into its nested timeline.
6. Select the alien’s head, then convert it into a Graphic Symbol called “Head” (Modify > Convert to Symbol)
7. Do the same thing for its “LeftArm,” “RightArm,” “Top,” and “Bottom.” As you convert these pieces into symbols, notice that they appear in your Library Panel.
8. As you convert your Drawing Objects to Symbols, you may notice a change in your alien’s appearance. To fix this, simply right-click on one of the symbols (ex. “Head”) and choose Arrange > Bring to Front. Make sure that both of your alien’s arms are behind its top.

Distribute each graphic symbol to its own layer
9. In your Layers Panel, create 4 more layers (so that you have a total of 5 layers). Name them as follows:
· Head, Top, Bottom, Left Arm, Right Arm
10. It is important that each part of your alien is on its own separate layer. To achieve this, click on the layer that your alien is currently on. Select the alien’s “Bottom,” then right-click on it and choose “Cut.” Click on the layer named “Bottom” then right-click the stage and choose “Paste in Place.” This pastes the symbol in the exact same location it was in on the original layer.
· Note: You may want to rearrange your layers a little bit so that your alien looks more natural
11. Do the same thing for each part of your alien. When you are finished, each part should be isolated on its own separate layer. You can check this by toggling the Visibility of each layer in the Layers Panel.





Change the orientation point
12. Select your alien’s “Right Arm” then click on the Free Transform tool.
13. Grab the little white circle in the middle of the arm’s bounding box and drag it towards the alien’s armpit (it should automatically snap to the alien’s side). This is how you can change the rotation point of an object, which is going to come in handy when waving the alien’s arms.
14. Do the same thing for your alien’s “LeftArm.”

Animate the graphic symbols on the nested timeline
15. [image: Capture]Right-click on the alien’s “Right Arm” and choose “Create Motion Tween.” Flash converts the current layer into a Tween layer and inserts 1 second’s worth of frames (in our case, 24) so that you can begin to animate your symbol.
16. Shorten the animation by deleting frames 13-24 (select the frames, right-click > Remove Frames)
17. For each of the other 4 layers, add 11 more frames by right-clicking on each layer’s 12th frame and choosing “Insert Frame.” This will cause the other parts of the alien to show up on frame 12.
18. Click on your alien’s “Right Arm” again. Make sure that your “Right Arm” layer is selected, and that the playhead (the red thing on your timeline) is set at frame 12.
19. Choose the Free Transform tool (if you haven’t already) and drag the corner rotation control points to rotate the arm upward to the alien’s shoulder height.
20. Click on your alien’s “Left Arm.” Make sure that your “Left Arm” layer is selected, and that the playhead is set at frame 1. Right-click on the “Left Arm” and choose “Create Motion Tween.” Again, delete frames 13-24.
21. Drag the playhead to frame 12 and rotate your alien’s “Left Arm” so that it’s at the same height as the “Right Arm.”
22. Press Ctrl + Enter to test your movie! 
· It likely looks a little choppy. You can fix this by copying and pasting, then reversing your frames like you did in Exercise 3.
23. Shift + Select frames 1-12 on your “Right Arm” layer, copy the frames, paste frames on frame 13, then reverse the frames. Repeat for the “Left Arm” layer. Add 12 more regular frames to the other 3 layers so that the rest of the alien shows up on frame 24. You should now have 24 frames on each layer!
24. Press Ctrl + Enter to test your movie.
· The arm-waving motion should now be a lot smoother.









Exit back to the main timeline
25. Exit back to the main timeline by clicking the “Scene 1” text in the top left corner of your window.
26. Press Ctrl + Enter to test your movie!
· Notice how, even though the main timeline only has a single frame on it (1/24th of a second), the alien’s nested animation continues to loop over and over again.  If you do not want this to occur, use a Graphic Symbol for your nested animation, rather than a Movie Symbol.

Create a custom motion path to animate the movie symbol on the main timeline
27. On your main timeline, right-click the alien and choose “Create Motion Tween.”
28. Create a new layer, and make sure that frame 1 is selected.
29. With this new layer selected, choose the Pencil tool and draw a path from one side of the stage to the other that you would like your alien to follow.
30. Select the path you just finished drawing, then right-click and choose “Cut.”
31. Select the “Alien” layer. 
32. Right-click on the stage and choose “Paste in Place.” Your alien symbol should automatically attach itself to your new custom motion path! 
33. Delete the “new layer” that previously contained the custom path.
34. Press Ctrl + Enter to test your movie.
· Yikes! Your alien might be moving waaaaay too fast. That’s because you’re trying to cram your whole animation into 1 second! If this is the case, simply hover your mouse overtop of frame 24 on your timeline. When the double-sided arrow appears, click and drag your Tween to extend it across the desired number of frames!

Save and Export
35. File > Export > Export Movie > .swf file format (name it nestedmov).
36. Save your working file (aka .fla file) and exit.

[image: Capture2]




















Info Break: Inverse Kinematics (i.e. The Bone Tool)
1. What are “inverse kinematics”?
· Essentially, it is the method of animating objects by using bones to create armatures. Instead of animating on a regular timeline using keyframes and tweens, you animate on an Armature timeline using poses and positions.
2. What are “Bones”?
· When your animation object consists of multiple limbs and joints, you can use Animate’s Bone Tool (it looks like a little bone icon) to draw in bones for each limb! Together, these bones for a skeleton. To make create a realistic skeleton that moves as a real limbed object would, you simply connect your bones together at the object’s joints.
3. What are “Armatures”?
· An armature is just a fancy-pants term for a skeleton. It is what your animation object is called once you’ve added a set of bones to it.
4. What types of objects can I use Inverse Kinematics on?
· Shape Objects
· Movie Clips (recommended)
5. Why would I want to use Inverse Kinematics?
· It is WAY easier than redrawing your limbs every time you want a new movement to occur
· Bones and joints mimic the bones and joints of REAL limbed objects, making motion appear more natural
· When using Inverse Kinematics, Animate automatically adds “tweens” (aka “positions”) between each different key movement along your timeline

__________________________________________________________________________________________


Exercise 8: Inverse Kinematics: The Bone Tool (save as bonemov)
· Open the “skeletonmov” .fla file from the Shared > Hammond > Hand Out > 2D Animation folder
· Save this file as skeletonmov(.fla) within your “Exercises” folder
· A video version of this tutorial is available by clicking here!
· Artwork Credit: Gail Blumberg of Adobe Creative Cloud

Convert each of the skeleton’s major bones into Movie Clip symbols, then rig them together to create an armature using the bone tool! Once rigged, add a rocky slope to your stage, then animate your skeleton so that it moves from a standing position to a leaning position!
· For this exercise, you will be converting each individual body part of your skeleton into a Movie Symbol

Use the Following Techniques:
· Converting a group of Drawing Objects to a Movie Symbol
· Using the bone tool to add bones to a drawing object
· Connecting bones together to form an armature
· Animating an armature using poses

Instructions:
Set up your stage
1. Set the movie properties so that the stage is 800x600 px (or 11.11 x 8.33 inches), the frame rate is 24fps (if it is not already), and the ruler unit is inches (Modify > Document). 
2. Change the colour of the stage to a colour that complements the skeleton (or leave it as the default blue).



[image: C:\Users\admin\Desktop\Capture.PNG]Convert each group of drawing objects to a movie symbol
3. Take a look at the artwork on your stage. Click on each part of the skeleton – notice that there are 11 separate parts in total, and that each is either a Group of Drawing Objects or an individual Drawing Object. 
4. Select each separate part of the skeleton and convert it into a Movie Clip symbol (click on the part then Modify > Convert to Symbol OR f8). Name each symbol after the body part it represents. Here is what you should come up with:
· Skull, Ribs, Right Upper Arm, Right Lower Arm, Left Upper Arm, Left Lower Arm, Pelvis, Right Upper Leg, Right Lower Leg, Left Upper Leg, Right Lower Leg
Inside the Library panel, there should now be 11 Movie Clips.

Adding bones to your movie symbols to create an armature
5. Click on the Bone tool (in the Tools panel, it looks like a little bone icon).
6. With the Bone tool selected, click on the “Ribs” movie symbol to select it, then click on the upper-midsection of the skeleton’s rib cage and drag up until you reach the Skull movie clip. Let go. By doing this, you are setting the primary point or, the bone from which the rest of the bones will branch off from!
· Now the Ribs symbol and Skull symbol are part of the same armature because the bone you just drew is connecting them!
· You will also notice that in the timeline, the layer containing your skeleton has been converted to a special armature layer. Rename this layer “Skeleton.”
7. [image: C:\Users\admin\Desktop\Capture3.PNG]With the Bone tool selected, draw another bone connecting the Primary point to the right shoulder, then to the left shoulder, then down to the pelvis. Draw another bone from the pelvis to the right upper leg, and another from the pelvis to the left upper leg.
· The location of your bones does not have to be (and will not be) perfect – i.e. they do not have to line up exactly with each body part.
· If you mess up on your bone placement and want to redo one, simply click on the bone you want to remove and hit the Delete key to remove it!
8. With the Bone tool selected, draw another bone connecting the right shoulder to the right upper arm, and one connecting the left shoulder to the left upper arm. Do the same for the legs (right upper leg to right lower leg and left upper leg to left lower leg).
9. Play around with your newly armatured skeleton – practice moving the arms, legs, etc.! To move a limb in relation to its joint (which is what you want) hold use the Selection Arrow to click on the joint, then hold down Shift as you move the limb to the desired position.
· If you don’t hold shift, the limb will moved independent to its joint, and will actually “come apart” from the body – try it if you don’t believe me!
· WARNING: Sometimes when you hover over a bone while trying to move it, a Pushpin icon pops up. If you click on your bone while this icon is visible, you will Pin the limb, meaning that it will no longer rotate. If this happens, you can unpin it by hovering and clicking once more.
· TIP: You can also adjust the joint constraints for each bone to make the angles of rotation more realistic. To do this, select your bone then navigate to the Properties Panel > JOINT:ROTATION, then check off the “Contrain” box and adjust the Left Offset and Right Offset!

Animating your armature on the timeline
10. Notice that since your skeleton has been moved to the new armature layer, you have an empty layer! On this layer, draw a grey rectangle and align it in the bottom left corner. Use the white Sub-selection arrow to grab the top right corner of the box and drag it inwards so that a slightly inclined slope is created. Rename this layer “Slope.” 
11. Insert 39 more regular frames (click frame 40 > f5) on Slope layer and add a keyframe on frame 40 to lengthen your animation.
12. Lock your “Slope” layer (by pressing the lock icon beside the Slope layer’s timeline) so that you don’t accidentally edit the slope object.
13. Select frame 40 on your Armature layer. On this frame, position your skeleton so that it is leaning on the rectangle. You will likely need to a) select the entire skeleton and move it closer to the slope.
· To do this, select your entire skeleton, then click the Free Transform tool. A bounding box will surround your skeleton, and once it does you may click on it and drag it towards the Slope. You MUST use the Free Transform tool to move an entire armature. If you try to use the Selection Arrow, it will only move individual bones.
Next, move the Upper Left Arm and Lower Left Arm individually. 	
· [bookmark: _GoBack]To do this, use your Selection Arrow to select each individual limb. Don’t forget to hold down shift as you move them! Now you should have 2 poses on your armature (Skeleton) timeline! One on frame 1 and another on frame 40.
14. Press Ctrl + Enter to test your animation. Notice that your skeleton doesn’t pause for very long after it has finished leaning.
15. Add another 32 regular frames to both your Skeleton and your Slope layer so that your skeleton pauses for a short time once it has finished moving across the stage and leaning.

Save and Export
1. File > Export > Export Movie > .swf file format (name it skeletonmov).
2. Save your working file (aka .fla file) and exit.
[image: C:\Users\admin\Desktop\Capture4.PNG]
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