LaPelota Exercises
*For this activity, leave your stage SZ at the default of: 550 x 400 px & FR at 24fps

Info Break: User Interactivity & ActionScript
1. What does “user interactivity” mean?
· It means that whoever watches your animated movie has some control over what happens. For example, when the viewer clicks a button, a different graphic with more information might be displayed or a song may begin to play.

2. How complicated is it to add user interactivity?
· It depends. Interactivity can be simple, such as a button click or it can be complex, such as receiving inputs from a variety of sources such as the movements of a mouse, or keystrokes from the keyboard. In this course, we are only going to focus on simply ActionScript, mostly using buttons.

3. What is ActionScript?
· ActionScript is a scripting (and coding) language used to achieve most of the interactivity in Flash. Luckily, you do not need to be a coder to use ActionScript in Flash – it has a pile of built-in codes for you to choose from. You just need to know which ones to choose, and where/how to install them along your timeline.

4. How does ActionScript work?
· Basically, it provides a set of instructions that tell each button in your movie what to do when the user clicks on it.

5. Buttons?
· Remember the 3 types of symbols available in Flash? Graphic, Movie and… Button! A button is just a clickable symbol that allows you to enable ActionScript in your movie. Buttons can look like virtually anything – a shape, image, graphic or text.

-------------------------------------------------------------------------------------------------------
Mini-Lesson Movie
· Create a new folder inside your “CGI” folder called “La Pelota.” This is where you will save everything related to this exercise.
· Open a new flash document (ActionScript 3.0)
· Save this file as “la-pelota” (note: this is Spanish for “the ball.”) Click Save.
Step-by-Step 1: Creating a Simple Bouncing Ball
· Create a 10-frame animation that depicts a ball bouncing up and down by using a Graphic symbol and a Classic tween.
Use the Following Techniques:
· Creating graphic symbols
· Creating classic tweens



Instructions:
1. Click on Layer 1 to select it. Rename it “Ball.”
2. On the timeline, click on Frame 1 to select it. In the Tools Panel, select the Oval tool. Set the Stroke color to None. Set the fill color to whatever color tickles your fancy.

[image: ]

3. Draw a circle near the middle of the stage. Make it approx. 85 pixels (1.20 inches) in diameter.
· Use Drawing Object NOT Shape mode
4. Select your circle, then convert it to a Graphic Symbol (Modify > Convert to Symbol > Type: Graphic, Name: Ball). Your symbol will now be stored in the library in case you need it again.
5. Make sure that your ball is placed right in the middle of the stage.
6. On the timeline, select frame 5 and insert a keyframe (right-click > Insert Keyframe or F6).
7. Right-click on the timeline anywhere between frame 1 and 5 and create a Classic tween (right-click > Create Classic Tween). The space between the frames should change colour, and a black arrow should appear.
8. On the timeline, select frame 5, then use the Selection arrow to drag the circle to the bottom of the stage (tip: hold down the Shift key to help guide your dragging).
9. On the timeline, select frame 10, then insert a keyframe. Right-click anywhere between frame 5 and 10 and create a Classic tween.
10. On the timeline, select frame 10, then use the Selection arrow to move the circle back to the middle of the stage where it began (tip: use Onion Skinning to help you see where the original circle was).
11. Click Ctrl + Enter to test your animation. Save.
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Step-by-Step 2: Changing the Color of the Ball
· Add a color-changing effect to your bouncing ball that spans across 35 frames.

Use the Following Techniques:
· Changing the “Tint” color effect
· Using Onion Skinning

Instructions:
1. On the timeline, select frame 5, then select the circle. 
2. In the Properties tab, choose Color Effect > Style: Tint. Click the color picker beside the Style drop-down menu and select any tint color your heart desires. Since have already applied a Classic tween between frames 1 and 5, your ball will now transition smoothly from one color to the next.
3. On the timeline, select frame 15, then insert a keyframe. Right-click anywhere between frame 10 and 15 and create a Classic Tween.
4. Select frame 15, then drag the circle to the bottom of the screen.
5. With both frame 15 and the circle selected, use the Properties tab to change the Tint to a new color.
6. Repeat steps 3-5 every 5 frames, changing the position and color of the circle each time. Stop when you reach frame 35 (note: if all goes according to plan, the ball in frame 35 will be positioned at the bottom of the stage).
7. Click Ctrl +Enter to test your animation. Save.
· The circle should be transformed into a color-changing bouncing ball animation that lasts approximately 1.5 seconds long. Don’t worry if it looks a little jerky at the end. We will fix this in the next lesson.
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Step-by-Step 3: Creating Special Effects
· Add a growing and disappearing effect to your ball that spans across frames 40-75

Use the Following Techniques:
· Changing the “Brightness” color effect

Instructions:
1. On the timeline, select frame 40, then insert a keyframe. Create a Classic Tween between Frames 35 and 40.
2. Select frame 40, click on the ball, then use the Properties tab to change the tint color once more.
3. Select frame 75, then insert a keyframe. On frame 75, select the ball and use the Align panel to align it to the center of the stage.
4.  Use the Free Transform tool to make the ball larger (tip: hold down the Shift button while dragging from the corner to maintain the ball’s aspect ratio). Make your circle so large that the top almost touches the top of the stage, and the bottom almost touches the bottom of the stage.
5. In the Properties tab, choose Color Effect > Style: Brightness. Set the Brightness to 100%. The ball should become so bright that it seems to disappear from view!
6. Create a Classic tween between frames 40 and 75.
7. Click Ctrl + Enter to test your animation. Save.
· [image: C:\Users\admin\Desktop\2.PNG][image: C:\Users\admin\Desktop\3.PNG][image: C:\Users\admin\Desktop\1.PNG]Between frames 40-75 your ball should change color, grow larger, then disappear.


Step-by-Step 4: Creating Animated Text
· Animate the words “Spanish” and “Lesson” so that they appear on the page.

Use the Following Techniques:
· Converting text to graphic symbols for animation

Instructions:
The “Spanish” Layer
1. Create a new layer and rename it “Spanish.”
2. On the Spanish layer’s timeline, select frame 75, then add a keyframe. This keyframe will have a white (aka blank) circle inside of it. This is because no object has been drawn on this keyframe yet!
3. In the Tools panel, select the Text tool. In the Property tab, choose Character > Family: “insert whichever family you want”, Style: Regular, Size: 40. Use the Color picker to change the color to whatever you’d like.
4. Make sure frame 75 on the Spanish layer is selected, then click on the stage (aim for halfway up the stage, and slightly left of center) and type “Spanish.” Drag the sides of the word’s bounding box inwards so that the sides of the box are tightly aligned with the edges of your letters. This will make your text easier to work with.
5. Use the Selection tool to select the text. Modify > Convert to Symbol > Type: Graphic, Name: Spanish Text. The symbol will now be available in your library.
6. On the Spanish layer’s timeline, select frame 90, then insert a keyframe.
7. On the timeline, right-click somewhere between frame 75-90 and insert a Classic tween.
8. Return to frame 75, select the text, then use the Free Transform tool to reduce its scale so that it is approximately half its original size.
9. On frame 75, use the Selection tool to select the text. In the Property tab, choose Color Effect > Style: Brightness, Bright: 100%.
10. Click Ctrl + Enter to test your animation. Save.
· Between frames 75-90 the “Spanish” text should slowly appear, while also growing in size.

The “Lesson” Layer
11. Create a new layer and rename it “Lesson.”
12. On the Lesson layer’s timeline, select frame 85, then insert a new (blank) keyframe.
13. In the Tools panel, select the Text tool. In the Properties panel, choose Character > Family: “insert whichever family you want”, Style: Regular, Size: 40. Use the Color picker to change the color to a different color than what you used for “Spanish.”
14. Make sure frame 85 in the Lesson layer is selected, then click on the stage (aim for the right side of the word “Spanish”) and type “Lesson.”
15. On frame 85, use the Selection tool to select the text then Modify > Convert to Symbol > Type: Graphic, Name: Lesson Text. This symbol will be available in your library.
16. On the Lesson layer, select frame 100, then insert a keyframe.
17. On the Lesson layer’s timeline, click somewhere between frame 85 and 100 and insert a Classic tween
18. Select frame 85, hold down Shift, and drag the “Lesson” text to the far right side of the stage.
19. Use the Selection tool to select the “Lesson” text. In the Properties tab, choose Color Effect > Style: Brightness, Bright: 100%.
20. Make the text on the Spanish layer stay on the stage for the same length of time as the text on the Lesson layer. (hint: select frame 100 on the Spanish layer and insert a regular frame).
21. Click Ctrl + Enter to test your animation. Save.
· Between frames 75-90, “Spanish” should appear slightly left of center. Between frames 85-100, “Lesson” should appear from the right margin then stop when it is aligned with “Spanish.” The animation will loop. 

The “One” Layer
22. Create a new layer and rename it “One.”
23. On the One layer’s timeline, select frame 101, then insert a keyframe.
24. Select the text tool. In the Properties tab, choose Character > Family: “whatever you want”, Style: Regular, Size 95. Use the Color picker to change the color to a different color than what you used for “Spanish” and “Lesson.”
25. Make sure frame 101 is selected, then click on the stage (aim for the right side of the word “Lesson” – note: you should likely use Onion Skinning to help you with this) and type “1”
26. Use the Selection tool to select the text then Modify > Convert to Symbol > Type: Graphic, Name: 1 Text. This symbol will be available in your library.
27. On the One layer, select frame 110, then insert a keyframe.
28. On the timeline, right-click somewhere between frame 101 and 110 and create a Classic tween.
29. Select frame 101 then use the Selection tool to select the “1” text. In the Property tab, choose Color Effect > Style: Brightness, Bright: 100%
30. Select frame 110 then use the Selection tool to select the “1” text. In the Property tab, choose Color Effect > Style: Brightness, Bright: 40%
31. Make the text on the Spanish and Lesson layers stay on the stage for the same length of time as the text on the One layer. (select frame 110 on the Spanish and Lesson layers and insert a regular frame).
32. Click Ctrl + Enter to test your animation. Save.
· Between frames 101-110 the “1” should slowly fade in.
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Info Break: Button Symbols
1. What is a button symbol?
· A kind of symbol that creates animation via the click or roll of a mouse. It has four special states, or keyframes, that determine how the button appears.

2. What are the 4 “states” or keyframes within a button symbol?
· Up State: shows the button as it appears when the mouse is not interacting with it
· Over State: shows the button as it appears when the mouse is hovering over it
· Down State: shows the button as it appears when the mouse button is pressed
· Hit State: indicates the clickable area of the button


3. What do buttons look like?
· Buttons can look like virtually anything – an image, shape, graphic, or bit of text. They don’t necessarily have to be those oval-shaped gray rectangles you see on so many websites!

4. Where can I find buttons?
· You can insert bitmap or vector images and turn them into buttons or draw your own buttons using Flash’s drawing 
[bookmark: _GoBack]
Step-by-Step 5: Creating Navigation Buttons
· Create and place a button symbol that will eventually “Start” your animation.

Use the Following Techniques:
· Creating content that is added directly to the library (rather than the stage)
· Creating a button symbol
· Editing a button timeline

Instructions:
1. At the top of your window, click Insert > New Symbol > Type: Button, Name: Start Button. Creating a symbol before drawing an object on the stage will result in a new symbol being added to the library. This symbol can be edited and/or added to the stage later. When you click OK Flash opens a blank stage: you have now entered inside of your symbol and its timeline (the same way you do when using nested animation).
2. Inside this symbol there is 1 layer with only 4 frames: Up, Over, Down, and Hit. These are the only frames you can work with, when it comes to a button.
3. Click the Oval tool. In the Property tab, set the Stroke color to black and the Fill color to something light. Change the Stroke Weight if you wish.
4. Draw an oval in the center of the stage. Aim for it to be approx. 90 x 60 pixels (1.25 x 1 inch) in size. 
5. Select the Text tool. In the Property tab, choose Character > Family: “whatever you want”, Style: Regular, Size 20. Change the color to Black.
6. Click on the stage and use the Text tool to type “START.” Use the Selection arrow to drag the word onto the center of the oval. 
7. Select the “Over” frame. Insert a keyframe. 
8. With the Over keyframe selected, change the oval’s fill color to a darker version of your color.
9. Select the “Down” frame. Insert a keyframe.
10. With the Down keyframe selected, change the text’s color.
11. Select the “Hit” frame. Insert a keyframe. 
12. Select the Oval tool and use it to draw another oval overtop of the original oval. Aim for it to be approx. 150 x 112.5 px. It does not matter what colour it is – just where it is placed, since the “Hit” frame is not visible. Placing this larger oval overtop of the smaller oval simply defines a larger clickable area, so that the button becomes clickable outside the visible button (you’ll see). 
13. Click the “Scene 1” at the top of the stage to exit the nested timeline and return to your main timeline and stage.
14. Insert a new layer in Scene 1 and name it “Start Button.” Select frame 110, then insert a keyframe.
15. Click on the Library tab and find the “Start Button” you just created. Drag your button onto the stage, just below “Spanish Lesson 1” text.
16. Click Ctrl + Enter to test your animation. Save.
· You will not be able to see the “Over” and “Down” effects you created on your Start button’s timeline yet, since the animation will continue to loop… until we add ActionScript!
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Info Break: The Rules of Using ActionScript
1. You said I don’t need to be a coder to use ActionScript… how is this possible?
· Flash has a panel called the Code Snippets panel, which provides an easy, visual way to add ActionScript to your project. For the most part this is what you will be using in this course.

2. What is the difference between a Symbol and an Instance?
· A symbol is a reusable asset that you can use for tweening, animation or interactivity. An instance is a copy of a symbol that is created when you “drag a symbol” from the library to the stage. Think of the symbol as the original artwork. While there can only be 1 unique symbol, you can create infinite instances of that symbol to use throughout your animation.

3. What is it important to name all instances when using ActionScript?
· So far, you’ve been doing a good job of naming your symbols, but you likely haven’t really thought about naming your Instances. In addition to naming the original symbol, it is also important to name each separate instance of that symbol since ActionScript uses the instance names to reference the instance objects. An instance name should not be exactly the same as its symbol name.

4. How do I name my instance?
· Simply  use the Selection arrow to select the instance on the stage. In the Property panel, type in an Instance name.

5. Are there any rules I should follow when naming my instance?
· Use part of the original symbol name so that you know what the instance is
· Do not use spaces or special punctuation
· Do not begin a name with a number
· Be aware of capital and lowercase letters – instance names are case-sensitive

6. What are the ActionScript Codes and Code Snippets I will need to know when working with buttons?
· Snippet – Click to go to Scene and Play
· Snippet – Stop at this Frame 
· Code – gotoAndStop(framenumber);
· Code – gotoAndPlay(framenumber);
· Code – stop( );
· Code – play( );
· Code – nextFrame( );
· Code – prevFrame( );
· Code – SoundMixer.stopAll();

7. What if I get really good at this coding thing and I want to try new things?
· That would be excellent. Feel free to browse through the various Code Snippets inside the Actions panel and experiment through trial and error. The internet can provide you with access to TONS of different ActionScript codes, as well.

Step-by-Step 6: Adding Action to a Button
· Create a second scene, then add ActionScript to your Start button to take the user to that scene once the button is clicked. You will learn how and when to use the “Click to go to Scene and Play” and “Stop at this Frame” code snippets.

Use the Following Techniques:
· Working with multiple scenes
· Navigating between scenes using the Scene panel
· Naming symbol instances
· Using the Actions panel
· Inserting and editing Code Snippets

Instructions:
Adding and Navigating Between Scenes
1. Add a second Scene to your animation by clicking Insert > Scene. This will take you to a separate Scene, complete with separate stage and timeline. This will be the destination once your Start button is clicked.
2. To make navigation between Scene 1 and 2 easier, bring up the Scene window by clicking on Window > Scene. Drag the pop-up menu that appears and dock it at the top of your stage by clicking it, dragging it, and placing it at the top (a blue line will appear).
3. Return to Scene 1 by selecting it in the Scene panel.

Adding a “Click to go to Scene and Play” Code Snippet
4. On the Start layer’s timeline, select frame 110, then select the Start button on the stage. In the Property panel, name this instance “start_btn1” (do not include the quotations)
5. Make sure the start_btn1 instance is still selected. In the main menu click Window > Actions (the shortcut key = F9). The ActionScript panel should pop open, which allows you to work with ActionScript. You will be using ActionScript 3.0 (sound familiar?) throughout this course.
6. Inside the Actions panel, click on the “Code Snippets” (< >) icon in the upper right corner. The Code Snippets library, which contains a few different folders, will pop up.
7. Double-click on the “ActionScript” folder, then double-click on the “Timeline Navigation” folder to open it. Double-click the “Click to go to Scene and Play” code snippet to insert this command into your ActionScript Code Panel. Flash will automatically write and align the code for you inside the panel. A new layer called “Actions” will also be automatically added to your timeline (since you are adding Actions to a symbol, not the timeline).
· Included with each Code Snippet is a description of what the Code Snippet does to your animation, as well as instructions (if necessary – some codes don’t have any) on what you need to do to alter the code to suit your needs.
· Tip: Do not play with a code unless the instructions specifically tell you to. If you mess something up within the code and cannot figure out how to fix it, simply delete the code (or, if you messed up real bad, delete the Actions layer).
8. Read the instructions included with this code. They require you to replace “Scene 3” within the code, with the name of the scene you want to jump to once the button is clicked. In this case, that would be “Scene 2.” Highlight the green portion of the code that reads “Scene 3,” delete it, and replace it with code that reads “Scene 2” (the title of your desired Scene).
9. Close the Actions panel.
10. Notice that a new layer called “Actions” has been automatically created and that, on it, is a little lowercase “a.” This indicates that you have added “ActionScript” to that particular frame (110). The Actions layer is where all of your ActionScript codes will be placed.

Adding a “Stop at this Frame” Code Snippet
11. Again, on the Start Button’s timeline, select frame 110, then select the start_btn1 instance. 
12. Again, press F9 on your keyboard to bring up the Actions panel.
13. This time, inside the “Timeline Navigation” folder, double-click the “Stop at this Frame” Code Snippet to insert this command into your ActionScript code panel. Flash will automatically write, and align the code below the “Click to go to Scene and Play” code you inserted in Step 7. This Code Snippet will stop Scene 1’s timeline at frame 101 to prevent it from looping, and allow your viewer to click your button! Close the Actions panel.
· Note: Rather than add the code snippet for this command, you could type in the code by hand… since it is a very short and simple code. To do this, select the frame on the Actions timeline that you wish to stop at, then open up the Actions panel. Type “stop();” (minus the quotations) into an unused line number on the Code Panel. Close the Actions panel.
14. Press Ctrl + Enter to test your animation. Click Save.
· [image: C:\Users\admin\Desktop\3.PNG][image: C:\Users\admin\Desktop\2.PNG][image: C:\Users\admin\Desktop\1.PNG]All of the text, along with the START button, should remain stationary at the end of your animation. When you hover over your button, it should turn from a light color to a dark color and become clickable. When you click the button, the text should turn a different color and Scene 1 of your animation will replay…but only because you haven’t added anything to Scene 2 yet (thus your animation simply loops back around)!

Step-by-Step 7: Adding the Text Layer
· Create some instructions on Scene 2 of your minilesson movie, and align them on the stage.

Use the Following Techniques:
· Inserting and aligning text

Instructions:
1. In Scene 2, create a new layer and change the name to “Text.” Select Frame 1.
2. Click the Text tool. In the Properties panel, set the font to whatever you’d like, size 30. Set the color to a medium shade of whatever you’d like.
3. Click the top left corner of the Stage, then type “Listen to the phrase in both languages:” Play with the lines of your bounding box so that the phrase is all on one line, and the box’s lines are tight with the edges of the word’s letters. Select the phrase, then click Modify > Align > Left.
4. Click the stage again, below the previous phrase, then type “English.”
5. Click the stage again, below the previous phrase, then type “The Ball Bounces.”
6. Click the stage again, below the previous phrase, then type “Espanol.”
7. Click the stage again, below the previous phrase, then type “La Pelota Rebota.”
8. Use the Selection tool to select the word “English” In the Property panel set the size to 40 and the color to whatever you’d like. Make any necessary adjustments to the bounding box to ensure that the text is all on one line.
9. Make the same changes to the word “Espanol.”
10. Use the Selection tool to select the phrase “The ball bounces.” In the Property panel set the size to 25 and choose a different color.
11. Make the same changes to the phrase “La Pelota Rebota.”
12. Select the four text elements on your stage, then click Modify > Align > Left.
13. Your stage should look something like the image below. Save.
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Step-by-Step 8: Adding Buttons to the Movie
· Create some buttons, which will eventually play the phrases on your stage in English and Spanish.

Use the Following Techniques:
· Creating a play button
· Duplicating and renaming a symbol 

Instructions:
1. Using the drawing tools, create a “play button.” I recommend the circle or rectangle tool to draw the button, and the line tool to draw the play icon inside the button. If you are using separate lines/shapes, make sure to use Modify > Combine Objects > Union to combine them into a single moveable shape.
2. Make a copy of this drawing object (right-click > copy > paste). There should now be 2 on the stage.
3. Convert the first drawing object of the button into a button symbol by selecting it and clicking Modify > Convert to Symbol. Choose “Button” as the symbol type. Name it “Play Button – English”
4. Change the appearance of the “Over,” “Down,” and “Hit” frames by double-clicking on the button symbol to enter its nested timeline! (like you did in step 5). Remember – to make your button clickable, you MUST draw a clickable area around the button on the “Hit” frame.
5. Do the same for the second drawing object of the button. Name it “Play Button – Spanish”
· It is important to make a separate symbol, rather than a copy/duplicate/instance, because we will be adding audio to the symbol itself. Since we want two different sounds to play (one English and one Spanish), we must make two separate symbols. If we tried to add audio to a symbol’s instance, it would apply that same audio to all instances of that symbol. 
6. Make sure the instance of “Play Button - Spanish” is on the stage beside the “La pelota rebota” text. 
7. Your stage should look something like the image below. Save.
[image: C:\Users\admin\Desktop\1.PNG]






----------------------------------------------------------------------------------------------------------------------------------------

Step-by-Step 9: Combining Layers
· Copy and paste a symbol and timeline animation from another Flash document to add a bouncing ball to Scene 2.

Use the Following Techniques:
· Copy and paste layers from other Flash documents

Instructions:
*Before completing this Step-by-Step, copy and paste the “bouncer.fla” working file (.fla) from the Shared Drive (Hammond > Hand Out > 2D Animation > LaPelotaWorkingFiles) to your Flash folder into your own “LaPelota” folder. 

1. Open the “bouncer.fla” working file (but also leave your LaPelota file open at the same time). Inside the “bouncer.fla” file, click the “bouncer” layer name once to select all the frames in that layer. All frames in this layer should appear blue to indicate that they are selected.
2. Right-click on the layer name, then select “Copy Layers.”
3. Return to your “LaPelota” file. In Scene 2, right-click on your “Text” layer, then click “Paste Layers.”
· Note: When this happens, a “Resolve Library Conflict” dialog box might open. If this happens, simply select “Don’t replace existing items,” and click OK.
4. Close the “bouncer.fla” file without saving it. 
5. Extend the Play Buttons and Text layers so that they stay on the stage during the entire animation (hint: click frame 40 on each layer and add a regular frame). 
6. Press Ctrl + Enter to test the “bouncer” animation to make sure it works! Save. 
· The “bouncer” ball should bounce up and down and change colors a couple times before your animation loops back to the beginning of Scene 1 (we will fix this in a minute).

----------------------------------------------------------------------------------------------------------------------------------------

Step-by-Step 10: Creating a Film Loop
· Add ActionScript to prevent the animation from looping back to the beginning of Scene 1.

Use the Following Techniques:
· Insert a “gotoAndPlay( )” ActionScript code to loop animation

Instructions:
1. In Scene 2, create a new layer and name it “Actions.” Since we will be adding ActionScript to a frame on our timeline, rather than a symbol on our stage, Flash will not automatically make this layer for us. However, it is still important that we keep our ActionScript organized within 1 layer so it is simple to find and edit later on, if necessary.
2. Select the Actions layer and insert a blank keyframe on frame 40. In order to insert ActionScript on a timeline frame, there must be a keyframe present. 
3. Click F9 (or Window > Actions) to bring up the ActionScript panel.
4. In the Code panel, manually type in “gotoAndPlay(1);” The text  (but not the brackets and number) will turn blue if you’ve typed in the code correctly! Don’t forget to add the “;” to the end.
· Basically, what you’re doing by writing this code, is telling the animation to skip from frame 40 in Scene 2 back to frame 1 in Scene 2, rather than looping back to the beginning of Scene 1. Now, every time your animation reaches frame 40, ActionScript will direct it back to frame 1. Forever.
· “gotoAndPlay” is the code ActionScript uses to tell Flash to go backwards or forwards along the timeline and play a particular frame in your animation.
· “(1)” specifies the frame number inside your Scene that you wish the code to play.
5. Close the Actions panel. 
6. Click Ctrl + Enter to test your animation. Save.
· When your movie reaches the end of Scene 2, it should loop back to the beginning of Scene 2, rather than the beginning of Scene 1.
----------------------------------------------------------------------------------------------------------------------------------------

Step-by-Step 11: Adding Scene Links
· Add ActionScript to prevent the animation from looping back to the beginning of Scene 1.

Use the Following Techniques:
· Insert a “gotoAndPlay( )” ActionScript code to loop animation

Instructions:
1. On the Main Menu, click Insert > New Symbol > Name: Replay, Type: Button.
2. Inside the symbol’s timeline, rename Layer 1 to “Button.”
3. Select the “Up” frame of the Button layer. Select the Type tool and use it to type “Replay” on the stage. This will become the button that takes users back to the start of the animation.
4. Use the Selection tool to select the word “Replay.” Align the bounding box so that it is tight with the text. In the Property panel, set the font to Times New Roman, the size to 15, and the color to whatever you’re feeling at this time.
5. Select the “Over” frame of the Button layer, then insert a keyframe. With this frame selected, select the text and change the color to something different.
6. Select the “Hit” frame of the Button layer, then insert a keyframe. With this frame selected, use the rectangle tool to draw a rectangle surrounding the word “Replay.” Just like with the button from Step-by-Step 5, it does not matter what color this rectangle is, since it won’t actually show up on the stage – rather, it is used to define the clickable area of the button.
7. At the top of the window, click Scene 1 to exit the button’s timeline. 
8. In Scene 2, on the Text layer’s timeline, select frame 1. Drag an instance of the Replay button symbol to the bottom left corner of the stage. In the Property panel, rename this instance “replay_btn.”
· Remember: It is CRITICAL that, before adding ActionScript to a symbol, you give it a unique name that follows the instance naming rules (see ActionScript Info Break for details)
9. Make sure that the Replay button is the only object selected on the stage, then press F9 to open up the Actions Panel. 
10. In the Actions panel, insert a Code Snippet: Code Snippets > ActionScript > Timeline Navigation > Click to go to Scene and Play. Follow the directions, like you did in Step-By-Step 6, but this time change the scene number (in brackets) to 1, since we want to link back to the beginning of Scene 1!
11. Close the Actions panel. 
12. Press Ctrl + Enter to test your animation. Save.
· When you click the Replay button, the animation should loop back and restart at the beginning of Scene 1, frame 1 
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Info Break: Audio in Flash
1. What can sounds be used for in Flash?
· Anything from background music, to button clicks, to narration and sound effects.

2. Does Flash have any built-in audio and sound effects?
· Yes! In the Main Menu, click Window > Common Libraries > Sounds to bring up a pop-up box filled with common sound effects.

3. What types of audio files be imported into Flash?
· Flash supports MP3, WAV, and AIFF files. To check what type of file your audio is, right-click on the file > Properties, then in the pop-up box, check the “Type of File”

4. How do I get audio files into my animation?
· First, you must import them to the library by going up to the Main Menu > Import > Import to library. Your audio will then appear in the library and you can drag it from there onto the stage. Your audio will not appear on the stage, but in the timeline on the frame you had selected when you dragged the audio from the library.

5. Will Flash create a Sounds layer for sounds, like an Actions layer for ActionScript? 
· No, but it is best practise to keep all your sounds on a “Sounds” layer. This way you may edit them separately from your visual animation objects.

6. What do the different Sync options mean?
· Sync options affect how your song will play throughout your animation. There are 4 different types of Sync options. The one you will use the most is “Stream”:
· Stream – Used for long passages of music or narration when you want the sound to sync with the frames on the timeline.
· Event – Used for short sounds and events like button clicks, when you want the sound to start whenever an action takes place on a particular keyframe.
· Stop – Used when you want to stop a sound on a particular frame. You will never really use this option since, if you ever want to stop a sound within a Stream sync, you can simply insert a blank keyframe!
· Start – Used for short sounds and events like button clicks, when you want the sound to start whenever the playhead enters a particular keyframe. Unlike Event syncing, Start syncing does not trigger the sound if it is already playing (so there is no possibility of overlapping sound).

7. Can I edit and adjust my sound to better suit my animation?
· In fact, you can! To edit a sound, click on the first keyframe the sound is added to on the timeline, then in the Property panel, click the pencil icon beside “Effect” to bring up the Edit Envelop dialogue box. This will allow you to edit the sound’s wavelength, or “Envelope.” 2 major editing functions you will use are listed below:
· Clipping a sound – You may edit the length of your track either by seconds or frames by selecting the appropriate option. To trim the track, drag the black lines that surround the wavelength in/out, then click OK.
· Changing the volume of a sound - You may adjust the volume of the entire track, or of certain points along the track to produce fade-ins/outs by clicking the top horizontal line of the wavelength. A white box will appear. Dragging this box downward will result in a gradual or dramatic change in volume, depending on the steepness of the slope.
Step-by-Step 12: Importing Sound Files to the Library
· Import audio files into your project’s Library.

Use the Following Techniques:
· Import audio files into Flash
· Sample audio files within the project

Instructions:
*Before completing this Step-by-Step, copy and paste all sound files (in the image below) from the Shared Drive (Hammond > Hand Out > 2D Animation > LaPelotaSoundFiles) to your Flash folder.

[image: C:\Users\bhammond\Desktop\1.JPG]

1. In the main menu, click File > Import > Import to Library. Locate the audio clips you copied and pasted from the Shared drive and import them into the library by shift-selecting, then clicking Open.
2. Click on the Library tab to see if the files have successfully been imported to the library.
3. Select a sound file in the library. Test the sound file by clicking the TINY play button (near the top right of the Library panel, just above the clip’s sound wave image).
4. Create a new folder inside your Library panel (the tiny folder icon at the bottom of the panel). Name it “Sounds” and drag all the sounds inside of it. Feel free to create folders for your other symbols. This will keep you super organized!
5. Save.

----------------------------------------------------------------------------------------------------------------------------------------

Step-by-Step 13: Adding Sound to the Buttons
· Add sound to the Play Buttons in order to provide a spoken example of each phrase for users to click on!

Use the Following Techniques:
· Adding multiple instances of the same symbol
· Adding sound to a button symbol



Instructions:
1. In Scene 2, open the Library panel.
2. Double-click the “Play Button – English” button symbol to enter into, and edit its timeline.
3. Rename the existing layer “Button.” Create a new layer and name it “Audio.” Just like with ActionScript, it is important to keep your Audio layers separate from your animation layers so that they are easier to edit in the future.
4. Select the Audio layer, then select the “Down” frame and insert a keyframe.
5. Click on the Property panel > Sound > Name: the ball bounces(eng).wav, Effect: None, Sync: Event. You should notice a thin line appears through the center of your “Down” and “Hit” frames. This is what audio looks like within the frames of a timeline. If it does not appear on your “Hit” frame, simply add a regular frame to your “Hit” frame. 
6. At the top of the window, click on Scene 2 to exit the button’s timeline and return to Scene 2.
7. Click on your button to test out the audio. When you click on the “Play button – English” a lady should say “the ball bounces.” Not working? On the Main Menu, click Control > Enable Simple Buttons (make sure a checkmark is displayed beside this option). 
· Once you are finished testing, turn this option back off.
8. Repeat steps 2-7 to add audio to the “Play Button –Spanish,” except, instead of choosing the “the ball bounces(eng).wav” choose “the ball bounces(span).wav.”
9. Press Ctrl + Enter to preview your animation. Save.

----------------------------------------------------------------------------------------------------------------------------------------

Step-by-Step 14: Adding Background Music (sync: event)
· Add background music to Scene 1 for users to enjoy before clicking the START button.

Use the Following Techniques:
· Inserting audio into a timeline
· Using the Sound > Sync: Event option (in the Property panel)
· Using the Sound > Loop option (in the Property panel)

Instructions:
*Before completing this Step-by-Step, copy and paste the “backgroundmusic” sound file from the Shared Drive (Hammond > Hand Out > 2D Animation > LaPelotaMusic) to your Flash folder.

1. In the Main Menu, choose File > Import > Import to Library, then find and open the “backgroundmusic” MP3 file you copied and pasted from the Shared drive It will now appear in your LaPelota document’s library.
2. In Scene 1, add a new layer and name it “Audio-Background.”
3. On the Audio-Background layer, select frame 1. Go to the Library panel and drag an instance of the “backgroundmusic.mp3” onto the stage. A waveform should appear between frames 1-110 on your Audio-Background timeline. 
4. Make sure that frame 1 of the Audio – Background layer is selected, then go to the Property panel. Choose Sound > Sync: Event. Underneath the Sync option, change “Repeat” to “Loop.” This will cause your song to repeat infinitely throughout your movie (on BOTH Scene 1 and Scene 2). 
5. Press Ctrl + Enter to test your movie. Save.
· You should hear the background music play for approx. 15 seconds straight, then fade, then repeat. This will continue throughout both Scene 1 and 2. Forever.
To stop your background music from playing throughout Scene 2 (you may not want this, since it could be distracting when combined with your button sounds):
1. Go to Scene 2. 
2. On the Action layer’s timeline, click on frame 1.
3. Press F9 to bring up the Actions panel. 
4. On a new line, type the following code to stop all sounds from playing:
a. SoundMixer.stopAll();
5. Press Ctrl + Enter to test your movie. Save.
a. You should hear the background music playing. This will continue throughout Scene 1 until you click the START button. Once you enter Scene 2, the music should stop completely.
b. There is one problem with this: the stopAll code stops all sounds prior to the frame it is on, as well as during the frame it’s on. This will cause your play buttons to get wonky, since we’ve also got ActionScript on frame 40 telling your timeline to go back to frame 1, which contains your stopAll code
c. But there is a solution: On your Actions layer, select frame 40. Press F9 to bring up your Actions panel. Replace the “1” in the gotoAndPlay(2); code with a “2” so that we can bypass the stopAll code on frame 1 
	
----------------------------------------------------------------------------------------------------------------------------------------

Step-by-Step 15: Adding Sound Effects (sync: stream)
· Add a sound effect that takes place at the same time as the ball expands and disappears in Scene 1.

Use the Following Techniques:
· Inserting sound effects to the timeline
· Inserting sound effects from Flash’s built-in Sound library
· Using the Sound > Sync: Stream option (in the Property panel)
· Using the Sound > Repeat option (in the Property panel)

Instructions:
1. In Scene 1, add a new layer and name it “Audio-Ball.”
2. On the Audio-Ball timeline, select frame 40 (since this is where the ball on the Ball layer starts to expand, this is where we will start our sound effect) and insert a blank keyframe.
3. On the Audio-Ball timeline, select frame 75 (since this is where the ball on the Ball layer disappears, this is where we will end our sound effect) and insert a blank keyframe.
4. On the Audio-Ball timeline, select frame 40.
5. Go into your library > sounds folder and select the “inflation.mp3” sound effect. Drag the effect onto the stage. Its wavelength will now appear between frame 40 and 75.
· The sound stops at frame 75 because you added a new keyframe there
6. On the Audio-Ball timeline, make sure frame 40 is selected, then go into the Property panel > Sound and change the settings to: Sync: Stream, Repeat x1
· Choosing “stream” will limit the amount of frames that the sound is heard to the number of frames is occupies on the timeline.
7. Press Ctrl + Enter to test your movie. Save.
· You should hear a sort of swooshing sound as the ball expands and disappears. Once the ball has disappeared, so should your sound effect!
[image: C:\Users\admin\Desktop\1.PNG]-

----------------------------------------------------------------------------------------------------------------------------------------

If your movie works, then it’s time to begin creating YOUR interactive Mini-Lesson movie! 

FYI: Some resources for further exploration:
Using the Edit Envelope (Property panel > pencil icon) tool to fine-tune your audio:
http://edutechwiki.unige.ch/en/Flash_sound_tutorial

Adding advanced sound effects to your timeline (ex. An epic sword battle or dialogue):
[image: http://s2.quickmeme.com/img/c3/c3623f83662f62654ef0b0b4b25808aefed03b07c971161833f85e01690086f5.jpg]https://www.youtube.com/watch?v=82ju54yMvt4&nohtml5=FalseWarning: Adobe Flash is a sensitive program. This, combined with our less-than-stellar equipment, and your overachieving attitudes can result in some major crashing. Make sure to keep your file size as low as possible (i.e. use small image/audio files, few instances of frame-by-frame animation, and short run times). And for goodness’ sake SAVE & SAVE often. 
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/* Click to Go to Scene and Play
Clicking on the specified symbol instance plays the movie from the specified scene and frame.

Instruction:
1. Replace "Scene 3" with the name of the scene you would like play.

2. Replace 1 with the frame number you would like the movie to play from in the specified scene.
*/

start_btnl.addEventListener (MouseEvent.CLICK, fl_ClickToGoToScene);

function f1_ClickToGoToScene (event:MouseEvent) :void
1
MovieClip(this.root) .gotoAndPlay(l, "Scene 27);

/* Stop at This Frame

The Flash timeline will stop/pause at the frame where you insert this code.
Can also be used to stop/pause the timeline of movieclips.

*/

stop ()7
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