CHECK MAGAZINE TUTORIAL: PART 4
Inserting Images & Styling Text

In Part 4, you will learn…
Welcome to Part 4 of this six-part tutorial series on creating your first website. The first three parts showed how to define a site in Dreamweaver CS6, create the basic structure using <div> elements, and begin styling the home page with CSS. So far, the only image used was added as a background. In this part, you’ll learn how to add images in the HTML structure using the <img> tag. You’ll also add more text and style it, as well as create a translucent background and rounded corners with CSS.
[bookmark: articlecontentAdobe_numberedheader]
------------------------------------------------------------------------------------------------------------------------

Locate your files and review your task
[bookmark: articlecontentAdobe_text_0]If you are confident that you completed the first three parts of this tutorial series correctly, continue working with your existing files. If you’re not sure whether or not your HTML and CSS is correct, you can download the check_cs6_pt3completed file from the Shared folder, and use it to replace your existing files. In this part, you'll add the remaining content to the home page for Check Magazine, a fictional publication, by inserting images using the HTML <img> tag and formatting text. You’ll also add a translucent background and rounded corners to the main text area using CSS3 techniques. Figure 1 shows what the page will look like in a modern browser at the end of Part 4.

[bookmark: articlecontentAdobe_image][image: Figure 1. The page after you have completed the steps in this part of the tutorial series.]
The page after you have completed the steps in this part of the tutorial series.
[bookmark: articlecontentAdobe_numberedheader_0]------------------------------------------------------------------------------------------------------------

Insert images
[bookmark: articlecontentAdobe_text_2]You can use any of several methods to add images to a web page in Dreamweaver. In this section, you'll explore three commonly used methods to add images to the Check Magazine page.

Inserting an image using the Insert panel
One of the most common ways to add assets to a page is through the Insert panel or Insert menu.
1. In Dreamweaver, open index.html in the Check Magazine site.
2. Delete the placeholder text in the left_column <div>. Make sure the insertion point remains inside the <div> (see Figure 2). (In other words, make sure you don't click anywhere outside the <div> after you've deleted the placeholder text.)

[bookmark: articlecontentAdobe_image_0][image: Figure 2. The left_column <div> with the placeholder text deleted.]
The left_column <div> with the placeholder text deleted.

3. [bookmark: articlecontentAdobe_text_3]Press Enter (Windows) or Return (Mac) once to create more space in the <div>.
4. Press the up arrow on your keyboard to move the Insertion point back up to the top of the <div>, and click the Split button to see what has happened in the underlying code. Dreamweaver has inserted two paragraphs (<p> tags), each with &nbsp; inside them (see Figure 3).

[bookmark: articlecontentAdobe_image_1][image: Figure 3. Dreamweaver has inserted two empty paragraphs in the <div>.]
Dreamweaver has inserted two empty paragraphs in the <div>.

[bookmark: articlecontentAdobe_text_4]Note: The &nbsp; is the HTML entity (code that represents a special character) for a nonbreaking space. It’s there to make the paragraph easier to select in Design view. Dreamweaver normally deletes it automatically as soon as you start typing or insert anything into the paragraph.

5. In the Insert panel, select “Image.” Then, navigate to your “check_cs6” folder > images, and select the “car.jpg” then click “OK.”
[bookmark: articlecontentAdobe_image_2]

6. [bookmark: articlecontentAdobe_text_5]The image appears in Design view, and Dreamweaver inserts the necessary HTML in the underlying code, removing the nonbreaking space in the process. Inside the code, type “car” as the “alt” attribute.

[bookmark: articlecontentAdobe_image_3][image: Figure 5. The inserted car image and the underlying code.]
The inserted car image, alt=“car,” and the underlying code.

Note: The Property inspector is context-sensitive. Since you have the new image selected, it displays the most important properties for the car.jpg image. You can see that the Property inspector displays the file path (Src) to the image, the alternate text (Alt) that you specified in the Image Tag Accessibility Attributes dialog box, and the width (W) and height (H) of the image (see Figure 6). There are also options for giving the image an ID, converting it into a link or image map, and some simple image editing tools, such as “crop,” “brightness and contrast,” and “sharpen.” You can also manually resize the image within Design view by dragging the corners of its bounding box.


[bookmark: articlecontentAdobe_image_4][image: Figure 6. The Property inspector displaying image properties.]
The Property inspector displaying image properties.

[bookmark: articlecontentAdobe_text_7]Note too that the <img> tag is selected in the Tag selector (at the bottom of the Document window) — yet another way that Dreamweaver communicates the precise selection of page assets. Now you’re ready to add the remaining images.

Inserting an image by dragging
To insert an image by dragging:
1. Delete the placeholder text in the center_column <div>. Make sure the insertion point remains inside the <div>.
2. Press Enter (Windows) once to create more space in the <div>.
3. Press the up arrow on your keyboard to move the Insertion point back up to the top of the <div>.
4. In the Files panel, locate “images” folder, then the data_addict.jpg (it's inside the images folder) and drag it to the insertion point in the center_column <div> 

[bookmark: articlecontentAdobe_image_5][image: Figure 7. Drag the data_addict.jpg file to the insertion point in the center_column <div>.]
Drag the data_addict.jpg file to the insertion point in the center_column <div>.

5. [bookmark: articlecontentAdobe_text_8]In the code, type Data as the “Alt” attribute.

Insert an image using the method of your choice
To insert an image from the Assets panel:
1. Delete the placeholder text in the right_column <div>. Make sure the insertion point remains inside the <div>.
2. Press Enter (Windows) once to create more space in the <div>.
3. Press the up arrow on your keyboard to move the insertion point up to the top of the <div>.
4. Add the third image inside the “images” folder, “helmet.jpg” using one of the methods discussed above.
5. In the code, type Helmet as the “Alt” attribute.
6. Save the page.

[bookmark: articlecontentAdobe_image_6][image:  Figure 9. The page in Design view after inserting images in the columns.]
[bookmark: articlecontentAdobe_text_9][bookmark: articlecontentAdobe_image_24]The page in Design view after inserting images in the columns.

[bookmark: articlecontentAdobe_text_1][bookmark: articlecontentAdobe_numberedheader_1]-------------------------------------------------------------------------------------------------------------------------

Insert text
[bookmark: articlecontentAdobe_text_10]Now you'll add text to the columns. You can type text directly in the Document window or you can copy and paste text from other sources (such as Microsoft Word or plain text files). Later, you'll use CSS to format the text.

1. In the Files panel, locate the main.txt file in the assets folder and double-click the file's icon to open it in Dreamweaver. You'll notice that this window is in Code view and that the Split, Design, and Live buttons are disabled (see Figure 10) because it’s not an HTML file.

[bookmark: articlecontentAdobe_image_7][image: Figure 10. The text file opens in Code view only.]
The text file opens in Code view only.
[bookmark: articlecontentAdobe_text_11]
Note: Style sheets and JavaScript files also open only in Code view.

2. In the main.txt Document window, select the first block of text (beginning with "Inside Tesla Motors®" up to and including "read more...").
3. Copy the text by pressing Ctrl+C/Cmd+C, or by choosing Edit > Copy. Alternatively, you can right-click and select Copy from the context menu that appears.
4. Leaving the main.txt file open, click the tab of the index.html document.
5. Click inside the left_column <div> below the car image, placing the insertion point in the same place where you created space earlier.

[bookmark: articlecontentAdobe_image_8][image: Figure 11. The insertion point placed below the car image in the left_column <div>.]
The insertion point placed below the car image in the left_column <div>.

6. [bookmark: articlecontentAdobe_text_12]Paste the text by pressing Ctrl+V/Cmd+V, or by choosing Edit > Paste. Alternatively, right-click and choose Paste from the context menu that appears. The text is displayed in the <div>

[bookmark: articlecontentAdobe_image_9][image: Figure 12. The Inside Tesla Motors® text pasted in the <div>.]
The Inside Tesla Motors® text pasted in the <div>.

[bookmark: articlecontentAdobe_text_13]The text automatically inherits the font style that you set on the <body> element in Part 3 of this tutorial series. It needs some more formatting, but you’ll come back to that later.

7. Return to the main.txt file by clicking its tab.
8. Repeat the same process for the second (put this inside the “center_column”) and third (put this inside the “right_column”) blocks of text.

[image: Figure 13. The text in all three columns.]
The text in all three columns.

9. Close the main.txt file by clicking the X in its tab. 
10. Save the index.html

[bookmark: articlecontentAdobe_image_10]
[bookmark: articlecontentAdobe_text_15]
-------------------------------------------------------------------------------------------------------------------------

[bookmark: articlecontentAdobe_numberedheader_4]Format the text
[bookmark: articlecontentAdobe_text_36]Beginners often create class rules and apply them to each block of text, but that’s a very inefficient approach. It can also create problems for search engines, which rely on the HTML markup to understand how the content is structured. In Part 2, Creating the page structure, you used the Format pop-up menu in the Property inspector to format the main Check heading as Heading 1, which Dreamweaver wrapped in <h1> tags. The Format menu offers six levels of headings, which wrap the selected text in <h1> , <h2>, and similarly named tags through to <h6>. Browsers automatically display text in these tags in bold, progressively decreasing the font size for each level, with <h6> being the smallest. Inexperienced designers often use these heading tags to format bold text of a particular size, not realizing that search engines rely on these tags to determine the importance of the text inside them. Broadly speaking, a page should have one <h1> heading at the top, with <h2> tags introducing the next level of content, and <h3> tags used for subheadings. You rarely need to use <h4>, <h5>, or <h6>. As you have already learned, you can use CSS to change the default look of headings and other text. So, there’s no reason to misuse heading tags. CSS gives you much greater control over the look of text.

Note: The new HTML5 standard proposes using <h1> tags for the main heading in each section of a page, but this currently creates problems for search engines and assistive technology for the blind. For the foreseeable future, it’s best to stick with the hierarchy of headings I’ve just described.

Styling the main text area
The text that you copied from the main.txt file contains line breaks, but there’s no distinction between the headings and the rest of the text. In the following steps you’ll fix that, starting with the main_text <div> that’s superimposed on the main image.

1. In Design view, click inside the main_text <div> to position the insertion point at the end of the first line (after "OPERATIVE WORDS"). Notice there’s a heavy blue border around the <div> with a small rectangle at the top-left corner, as shown in the image below.

[bookmark: articlecontentAdobe_image_11][image: Figure 14. Absolutely positioned elements are surrounded by a special border when selected in Design view. ]
 Absolutely positioned elements are surrounded by a special border when selected in Design view.

[bookmark: articlecontentAdobe_text_16]This indicates that the element is absolutely positioned. The rectangle at the top-left is a handle that lets you drag the element to a different position, changing the offsets in your style sheet. Although some designers find this useful, there’s a danger of accidentally moving an absolutely positioned element when it’s selected in Design view. Keep clear of the handle when working with absolutely positioned elements.

2. Press Enter (Windows). As soon as you do so, a gap appears between the top of the <div> and the phrase "OPERATIVE WORDS." An even larger gap appears beneath it.
3. To understand what’s happened, open Split view and examine the underlying HTML 

[bookmark: articlecontentAdobe_image_12][image: Figure 15. The text has been split into paragraphs.]
The text has been split into paragraphs.

[bookmark: articlecontentAdobe_text_17]Note: When you pasted the text from main.txt, Dreamweaver placed it between the <div> tags. Pressing Enter/Return at the end of the first line split the text into two paragraphs. Browsers automatically add a top and bottom margin to paragraphs that is equivalent to the height of one line. That’s why the gap appeared at the top of the <div>.

Note: The larger gap below the phrase "OPERATIVE WORDS" is caused by the <br> tag before the word "Stumbling." The <br> tag causes a line break in text. Dreamweaver replaced the newline characters in the main.txt file with <br> tags when you pasted the text into Design view.

4. To get rid of the <br> tag, in Design view press the keyboard down arrow once to move the insertion point in front of the "S" of "Stumbling" and press Backspace. The <br> tag disappears, and the distance between the paragraphs is reduced.

Note: Although paragraphs have default top and bottom margins, the vertical space between two paragraphs is the equivalent of only one line because adjacent vertical margins merge to the height of the largest one. (Remember, this is what caused the main heading to push the header <div> away from the top of the page in Part 3.)

5. Put the insertion point at the end of the second line (after "Inner Circle"), and press Enter/Return.
6. Repeat the same process as in step 4 to get rid of the <br> tag by pressing the down arrow once to move the insertion point in front of "The" and pressing Backspace. You now have three paragraphs inside the main_text <div>. 
7. The first two paragraphs need to be formatted as Heading 2 and Heading 3 respectively. Click anywhere inside the first paragraph (OPERATIVE WORDS), and with the HTML button selected in the Property inspector, choose Heading 2 as the Format. This changes the <p> tags around "OPERATIVE WORDS" to <h2> tags.
8. Click inside the next paragraph, and set the Format in the Property inspector to Heading 3. The <p> tags around "Stumbling into Mark S.’s Inner Circle" change to <h3> tags. Don’t worry if the bottom of the main_text <div> moves down below its correct position. Design view gives only an approximate rendering of the page layout. Most layout flubs can be corrected by clicking on the Live view button.

[image: C:\Users\admin\Desktop\Capture.PNG]
Changing the second paragraph to an h3 element has caused it to go onto a second line

9. Click anywhere inside the “Stumbling into…” heading. In the CSS Designer panel, add a new selector called “.main_text h3” (reminder: if you click inside the element you wish to add a selector for, then click the “+” sign inside the Selectors section of the CSS Designer tab, Dreamweaver will create a very specific Selector for you). Add the following properties to the selector:
· Font-size: 16px
· Margin, all around: 0px
10. Click anywhere inside the "OPERATIVE WORDS" heading, and then add a new selector called “main_text h2.” Add the following properties to the selector:
· Margin, top: 0px
· Margin, bottom: 10px
· Color: Blue (use the eyedropper tool to select the blue color from helmet image)
· In the Type category, click the color box next to the Color field, and use the eyedropper tool to select the blue color from the image of the helmet.

[bookmark: articlecontentAdobe_image_13][image: Figure 16. You can use the color picker’s eyedropper tool to select colors from other parts of the page.]
You can use the color picker’s eyedropper tool to select colors from other parts of the page.

11. [bookmark: articlecontentAdobe_text_19]The paragraph at the bottom of the main_text <div> also needs adjusting. Click anywhere inside the "The star…" paragraph, and then add a new selector called “main_text p.” Add the following properties to the selector:
· Font-size: 14px
· [bookmark: articlecontentAdobe_image_14]Line-height: 20px
· Margin, all sides: 0px
12. [bookmark: articlecontentAdobe_text_21]In the Box category, leave the Same For All check boxes selected, and type 0 in the Top field under Margin. Click OK. The main_text <div> is now formatted, but there is no space around the text (see Figure 18).

[bookmark: articlecontentAdobe_image_15][image: Figure 18. The text has been formatted, but there’s no breathing space around it.]
The text has been formatted, but there’s no breathing space around it.
[bookmark: articlecontentAdobe_text_25]
13. To add some breathing space around the text in the main_text <div>, select the “.main_text” selector, then add the following property:
· Padding, all: 12px

[bookmark: articlecontentAdobe_image_16][image: Figure 19. The main text area is now nicely formatted.]
The main text area is now nicely formatted.

14. [bookmark: articlecontentAdobe_text_26][bookmark: articlecontentAdobe_text_27][bookmark: articlecontentAdobe_text_28]Choose File > Save All Related Files to save the web page and the style sheet.
-------------------------------------------------------------------------------------------------------------------------
[bookmark: articlecontentAdobe_numberedheader_3]Add a translucent background and rounded corners
[bookmark: articlecontentAdobe_text_29]All modern browsers support CSS effects that would have involved complex structures and background images until very recently. Two very simple effects are giving an element a translucent background and rounded corners. The effects won’t be seen by anyone using an old browser, such as Internet Explorer 8 or earlier. But that’s no reason to avoid giving users of modern browsers an enhanced experience.

To create a translucent background, you need to specify the color using what’s known as RGBA format. RGB represents the red, green, and blue components of the color. The A represents the color’s alpha transparency, expressed as a value between 0 (fully transparent) and 1 (fully opaque). 

1. To set both values for the background color of the “.main_text” div, select the “.main_text” selector, then add the following properties to the selector:
· Background-color: change the color mode from “hex” to RGBa (“a” stands for alpha – the transparency you set will not show up unless you’ve selected this color mode)
· Background-color: move the “alpha” slider from the top (1.0) to the approximately the same spot as depicted in the image below (0.8).

[bookmark: articlecontentAdobe_image_19][image: C:\Users\admin\Desktop\Capture.PNG]

2. Turn on Live view to see the effect. The background image is partially visible through the background of the main text area

[bookmark: articlecontentAdobe_image_20][image: Figure 22. The background of the main text area is now translucent.]
The background of the main text area is now translucent.
[bookmark: articlecontentAdobe_text_32]
5. Leave Live view on. To round the corners of the box, make sure that the “.main_text” selector is still selected, then add the following properties to the selector:
· Border-radius, all (under “Border” icon): 10px
[bookmark: articlecontentAdobe_image_21][image: Figure 23. Live view updates the rounded corners in real time, enabling you to adjust them to taste.]
Live view updates the rounded corners in real time, enabling you to adjust them to taste.

6. [bookmark: articlecontentAdobe_text_33]Choose File > Save All Related Files to save your work.
-------------------------------------------------------------------------------------------------------------------------

[bookmark: articlecontentAdobe_numberedheader_5]Fix the column headings
[bookmark: articlecontentAdobe_text_18]To fix the text in the three columns at the bottom of the page, you need to separate the headings from the rest of the text in the same way as in the main_text <div>.
1. Exit Live view if necessary. In the left_column <div>, place the insertion point after the ® symbol at the end of the first line, and press Enter.
2. Press your down arrow once to move the insertion point before the word "The."
3. Press Backspace to delete the unnecessary line break.
4. Click anywhere in the heading text (Inside Tesla Motors®). In the Property inspector, change the format from “Paragraph” to “h2.”

[bookmark: articlecontentAdobe_image_22][image: Figure 24. The column headings don’t inherit the same color as in the main_text <div>.]
[bookmark: articlecontentAdobe_text_34]The column headings don’t inherit the same color as in the main_text <div>.This is because the #main_text h2 style rule affects only <h2> headings in the <div> with the main_text class


5. Repeat steps 1-4 for “.center_column” and “right_column.”

[bookmark: articlecontentAdobe_image_23][bookmark: _GoBack][image: Figure 25. In Design view, the column headings are now formatted.]
 In Design view, the column headings are now formatted.

-------------------------------------------------------------------------------------------------------------------------


Review Questions:
1. What are 3 commonly used methods to add images in Dreamweaver?
2. What does the “&nbsp;” html entity do?
3. When you bring “text” documents into Dreamweaver, do they show up in Code view, Design view, or both? Why would it be useful to have your content typed out and added into an Assets folder ahead of time?
4. Why is it important to use H1-6 elements even though you can add bold/increased font effects through CSS?
5. When should you use the H1 element? H2? H3? H4/5/6?
6. What are some strategies you can use (since Design view is not always consistent) to ensure that your webpage looks like it is supposed to?
7. What is RGBA format? When you use it, why is it important to specify RGB colors as well?
8. What is a color’s “alpha” value? Which value is fully opaque: 1 or 0?

-------------------------------------------------------------------------------------------------------------------------

[bookmark: articlecontentAdobe_numberedheader_6]Where to go from here
[bookmark: articlecontentAdobe_text_35]The home page of the Check Magazine site is almost complete. In Part 5: Adding another page, you’ll create and link to a second page that uses most of the same styles, but looks very different.
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Stumbling into Mark S.’s Inner Circle
The star from Double Identity, who prefers
installing a skylight to the limelight, talks about
working on the one of the toughest film
shoots in history, family, and the starlet who’s
not doing a very good job of hiding in his
bathroom.
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